Foothills campus power outage
Incident Report for Colorado State University
Resolved
Power has been restored to Foothills campus.

Please submit a helpdesk ticket for any new issues related to this event.
Posted Apr 07, 2024 - 16:42 MDT
Investigating
XCEL is shutting down power to foothills campus, could be a 24 hour outage.


CSU Police & Safety
@CSUPoliceSafety
Power to CSU Foothills Campus will be shut off this afternoon and could be out for up to 24 hours.
Posted Apr 06, 2024 - 12:40 MDT
This incident affected: Infrastructure and Network (Campus Wired Network (Network and Connectivity Management) - Fort Collins, Campus Wireless (Network and Connectivity Management) - Fort Collins).